Installation Instructions

COMPATIBILITY NOTE

Arialshop v6 requires Node.js 10.x

Softwares Required

Download and install the following softwares

OR through terminal (Need chocolatey for windows)

# For Windows
choco install nodejs mongodb yarn python2
# OR for linux
sudo apt-get install nodejs mongodb yarn python2

Node Gyp

We also need node-gyp installed. Please follow the steps to install it https://github.com/nodejs/node-gyp#installation

Installation

Download and unzip the file from codecanyon and navigate inside the directory

cd arialshop

Start database

Start mongodb in a separate shell Run the follwoing commands from an elevated termnial/command prompt. In Windows operating system we can start it by opening the following file.

C:/Program Files/MongoDB/Server/3.2/bin/mongod.exe

Run the following 2 commands

This will install the required node dependencies and start the Server at http://localhost:3000 (Admin Panel), http://localhost:3001 (Store Front)

cd D:\arialshop\arialshop-admin
yarn
yarn dev
cd D:\arialshop\arialshop-store-front
yarn
yarn dev

That's it !!!

Now open http://localhost:3000 (Admin Panel) and http://localhost:3001 (Store Front)

Building files for production server

deployment

Add your logo/icon(512px*512px) to static directory of store-front (This step is essential to generate icons for Progressive Web App)

The follwing command will generate both client and server files inside dist directory which can be directly copied to production server

yarn prod

Now copy the files inside .nuxt and dist directory to the production server (For both store front and store back office)

Start the server

Login to cloud shell and run the following command

yarn start